Pgsql

Overview

pgsql - PostgreSQL DB Support

cPanel Documentation

Profile

Name PHP Version Profile Value Reverse Boolean?
pgsql 5 Cpanel::Easy::PHP5::Pgsql No

Compatibility

There are no known compatibility issues with this module.

Requirements

OS OS Version RPM/Package
CentOS/RedHat All postgresql
CentOS/RedHat All postgresql-devel
CentOS/RedHat All postgresql-server

Dependencies

This module requires PostgreSQL 7.3 or later.

Notes

EasyApache searches the following locations for the psql binary:

  • /usr/bin/
  • /usr/local/bin/

It then runs psql --version to determine the PostgreSQL version on your system.

EasyApache searches the following locations for the pg_config binary:

  • /usr/local/bin
  • /usr/bin

If the binary is not found, this module will be skipped.

If you enable this option, --with-pgsql=directory will be added to PHP's configuration options.

Vendor Documentation

PHP Version Documentation
Latest pgsql

History

Date EA Version Action Details Tracking #
2012-05-22 3.14.0 Removed PHP 4 support (Cpanel::Easy::PHP4::Pgsql) FB57536
Topic revision: r2 - 05 Jun 2013 - 18:32:50 - Main.LaurenceSimon