Page tree
Skip to end of metadata
Go to start of metadata

This document is for a previous release of cPanel & WHM. To view our latest documentation, visit our Home page.

For cPanel & WHM 11.42

Overview

Before you install cPanel & WHM or cPanel DNSONLY, make certain that your server's software meets the following minimum requirements for new installations.

Warning:

You must install Perl on your server before you can run the installation script for cPanel & WHM.

Supported operating systems

Operating systemAdditional restrictions

CentOS versions 5.x and 6.x

New installations of cPanel & WHM on CentOS servers must use CentOS version 6.0 or higher.
Red Hat Enterprise Linux® versions 5.x and 6.xNone.

CloudLinux 5.x and 6.x

cPanel does not support the use of Xen PV (paravirtualization) with CloudLinux.

Note:

We support all of the official production release kernels for these operating systems.

 

Supported virtual environments

Virtual environmentAdditional restrictions
KVMNone.
Linux-VServerNone.

Microsoft Server® 2008 Hyper-V

cPanel only supports the drivers and configurations that Microsoft provides.

OpenVZ

  • cPanel only supports stable releases.
  • CloudLinux™ is not compatible with OpenVZ.
Oracle VM VirtualBox, VirtualBox OSENone.

Virtuozzo™

CloudLinux is not compatible with Virtuozzo.
VMware® Server, VMware ESX ServerNone.
Xen, XenEnterprise™, XenExpress™, XenServer™None.

 

Virtual environments that are detected and reported as functional

 

Virtual environmentAdditional restrictions

SmartOS

In order for cPanel & WHM to detect SmartOS, you must use cPanel & WHM version 11.36.1 or higher.