Page tree
Skip to end of metadata
Go to start of metadata

EasyApache 4 does not use versioning and organizes changes by date only.

Each entry contains the following information:

  1. The package that we changed.
  2. The GitHub® repository link.
  3. The RPM's version.
  4. A description of the change.

For more information about our GitHub repository, read our The EasyApache 4 Git Repository and Build Updates documentation.

2018-12-5

  • ea-openssl
    • EA-8030 - Update OpenSSL to version 1.0.2q
  • ea-apache2-config
    • CPANEL-24111 - Gloval DCV passthrough breaks for hostname certificates
    • EA-8023 - Modify default,vhost template in ea-apache2-config-runtime for HTTPS redirect feature support
  • ea-tomcat85
    • ZC-4478 - Show error from port authority script when it fails to allocate ports 
    • ZC-4452 - Ensure that Tomcat disabled is for user when removing it from user's account.

2018-11-14

  • ea-tomcat85
    • EA-7998 - Tomcat Manager menu is not searchable in WHM 
  • libcurl
    • EA-7983 - ssh2 EA4 module addition with pecl breaks and requires manual package install of libssh2 
  • scl-phalcon
    • EA-7995 - Add macro for scl-php72 to add Phalcon and update to 3.4.1 
  • scl-php71
    • EA-8004 - Update to PHP 7.1.24, drop 7.1.23
    • Cleaned up the patch files
  • scl-php71-meta
    • EA-8005 - Update PHP 7.1 Meta Package to 7.1.24, drop 7.1.23
  • scl-php72
    • EA-8000 - Update to PHP to 7.2.12, drop 7.2.11
    • Cleaned up the patch files
  • scl-php72-meta
    • EA-8001 - Update PHP Meta Package to 7.2.12, drop 7.2.11

2018-11-7

  • scl-ruby24-passenger
    • EA-7982 - scl-ruby24 is breaking with the new libcURL 7.62.0
  • libcurl
  • ea-tomcat85
    • Move ea-tomcat85 into Production and out of Experimental.

2018-11-1

  • ea-apache2-config
    • Revert EA-7903 - ErrorDocument directive not being honored when using PHP-FPM and the filename provided has a .php extension

2018-10-31

  • ea-apache2
    • EA-7941 - Update ea-apache24 to 2.4.37
  • ea-apache2-config
    • EA-7903 - ErrorDocument directive not being honored when using PHP-FPM and the filename provided has a .php extension
  • ea-php56
    • EA-7957 - EasyApache 4 allows the installation of PHP-FPM packages without requiring ea-apache24-mod_proxy_fcgi
  • ea-php70
    • EA-7957 - EasyApache 4 allows the installation of PHP-FPM packages without requiring ea-apache24-mod_proxy_fcgi
  • ea-php71
    • EA-7957 - EasyApache 4 allows the installation of PHP-FPM packages without requiring ea-apache24-mod_proxy_fcgi
  • ea-php72
    • EA-7957 - EasyApache 4 allows the installation of PHP-FPM packages without requiring ea-apache24-mod_proxy_fcgi

2018-10-17

  • ea-php71
    • EA-7904 -Update PHP to 7.1.23, drop 7.1.22
  • ea-php72
    • EA-7908 - Update PHP to 7.2.11, drop 7.2.10

2018-10-10

  • ea-apache2
    • EA-7871 - Update ea-apache24 to 2.4.35
  • ea-apache24-mod_cpanel
    • EA-7386 - mod_cpanel requires the "/var/cpanel/suspended" directory which doesn't exist on servers which have never had suspended accounts.
    • EA-7821 - Don't strip debug symbols from the debug build of mod_cpanel 
  • ea-apache2-config
    • CPANEL-22676 - Contact navigation link is incorrect in /etc/apache2/conf/httpd.conf
    • EA-7373 - Primary ServerAdmin email address in httpd.conf is not updated when changed in Basic WebHost Manager Setup
  • libcurl
    • EA-7819 - CVE-2018-14618 curl NTLM password overflow via integer overflow EA4
  • mod_ruid2
    • EA-6667 - EasyApache should disable the Apache jail vhost tweak if mod_ruid2 is removed. 
  • scl-ruby24-passenger
    • EA-7381 - Update Passenger to 5.3.4

2018-9-19

  • ea-php56
    • EA-7842 - EA4 PHP 5.6 update to version 5.6.38 (with fix for CVE-2018-17082)
  • ea-php56-meta
    • Update to PHP to version 5.6.38, drop 5.6.37
  • ea-php70
    • EA-7829 - EA4 PHP 7.0 update to version 7.0.32 (with fix for CVE-2018-17082)
  • ea-php70-meta
    • Update to PHP version 7.0.32, drop 7.0.31
  • ea-php-71
    • EA-7833 - EA4 PHP 7.1 update to version 7.1.22 (with fix for CVE-2018-17082)
  • ea-php71-meta
    • Update to PHP to version 7.1.22, drop 7.1.21
  • ea-php-72
    • EA-7837 - EA4 PHP 7.2 update to version 7.2.10 (with fix for CVE-2018-17082)
  • ea-php72-meta
    • Update to PHP to version 7.2.10, drop 7.2.9

2018-8-29

  • ea-apache24-config - 1.0-136
    • EA-7261: Create EA3->EA4 symlinks even when EA3 file exists
  • ea-apache24-mod_ratelimit - 2.4.34-3
    • EA-7802: Restore mod_ratelimit back to the 2.4.34 version. Apply upstream fixes for it from trunk.
  • ea-openssl - 1.0.2p

2018-8-22

  • ea-apache24-mod_cpanel - 1.3-1
    • EA-7780 - mod_cpanel causing load issues
  • ea-apache2-config - 1.0-135
    • EA-7035 - The splitlogs binary's --dir argument default to '/usr/local/apache' on a system using EA4 
    • EA-7012 - Proxy subdomain vhost results in spurious SSL warning during Apache startup 
  • scl-php71 - 7.1.21
    • EA-7786 - Update PHP to 7.1.21, drop 7.1.20
  • scl-php71-meta - 7.1.21
    • EA-7787 - Update PHP Meta Package 
  • scl-php72 - 7.2.9
    • EA-7782 - Update PHP to 7.2.9, drop 7.2.8
  • scl-php72-meta - 7.2.9
    • EA-7783 - Update PHP Meta Package

2018-8-15

  • mod_suphp
    • EA-7779 - Revert change in EA-7525

2018-8-14

  • ea-cpanel-tools
    • EA-7549 - cPanel fails to update /etc/suphp.conf if it exists as a symbolic link 
  • ea-documentroot
    •  EA-7658 - Prevent caching of defaultwebpage.cgi redirect
  • ea-nghttp2
    • EA-7754 - Update nghttp2
  • mod_suphp
    •  EA-7525 - targetMode in 0008-Support-phprc_paths-section-in-suphp.conf.patch checked before set
  • scl-ioncube10
    • EA-7753 - Update ioncube 10.2.2 to 10.2.4
  • ea-apache2-config
    • EA-7777 - Apache default template causes splitlogs to log default vhost hits to wrong domlog

2018-7-25

  • ea-apache2
    • EA-7715: Fix bug in mod_ratelimit
  • scl-php54
    • EA-7526: ea-php*-php-fpm installs files that it does not own
  • scl-php55
    • EA-7526: ea-php*-php-fpm installs files that it does not own
  • scl-php56
    • EA-7526: ea-php*-php-fpm installs files that it does not own
    • EA-7733: Update PHP to version 5.6.37, drop 5.6.36
  • scl-php56-meta
    • EA-7734: Update PHP to version 5.6.37, drop 5.6.36
  • scl-php70
    • EA-7526: ea-php*-php-fpm installs files that it does not own
    • EA-7712: Update PHP to version 7.0.31, drop 7.0.30
  • scl-php70-meta
    • EA-7713: Update PHP to version 7.0.31, drop 7.0.30
  • scl-php71
    • EA-7526: ea-php*-php-fpm installs files that it does not own
    • EA-7708: Update PHP to version 7.1.20, drop 7.1.19
  • scl-php71-meta
    • EA-7709: Update PHP to version 7.1.20, drop 7.1.19
  • scl-php72
    • EA-7526: ea-php*-php-fpm installs files that it does not own
    • EA-7704: Update PHP to version 7.2.8, drop 7.2.7
  • scl-php72-meta
    • EA-7705: Update PHP to version 7.2.8, drop 7.2.7

2018-7-18

  • ea-apache24
  • ea-libcurl
    • EA-7654 - Update ea-libcurl to 7.61.0 (with fix for CVE-2018-0500)
  • ea-apache24-mod_cpanel
    • EA-7639 - mod_cpanel shows suspended for partial username.
  • ea-apache24-config
    • ZC-3914 - Update EA4 template to not do the concurrent open_basedir stuff anymore 
  • ea-apache24-mod_suphp
    • EA-7555 - /var/log/apache2/suphp_log removed when ea-apache24-mod_suphp uninstalled 
  • scl-ioncube10
    • EA-7609 - Update ioncube to 10.2.2, drop 10.2.0
  • ea-ruby24-ruby
    • EA-7201 - Set ownership for /opt/cpanel/ea-ruby24

2018-6-27

  • scl-php72
    • ZC-3899:  Update PHP to 7.2.7, drop 7.2.6
  • scl-php71
    • ZC-3903: Update PHP to 7.1.19, drop 7.1.18
  • scl-ruby24
    • EA-7560: Update Ruby to version 2.4.4
  • scl-ruby24-meta
    • EA-7560: Update Ruby to version 2.4.4
  • ea-apache2
    • EA-5971: htcacheclean will not start on CentOS 7
  • scl-ioncube10
    • EA-7374: Remove experimental from description
  • scl-ioncube6
    • EA-7374: Remove experimental from description
  • scl-ioncube5
    • EA-7374: Remove experimental from description

2018-6-19

2018-5-29

  • scl-php71
    • 7.1.18-1-EA-7506: Update PHP 7.1 to 7.1.18, drop 7.1.17
  • scl-php72
    • 7.2.6-1-EA-7510: Update PHP 7.2 to 7.2.6, drop 7.2.5
  • scl-sourceguardian
    • 11.2-1-EA-7324: Upgrade SourceGuardian loaders to the latest available. Update to 11.2, drop 11.0.6. Added 7.1 and 7.2 support.
  • ea-apache2-config
    • 1.0-130-EA-3773: mime.types paths are not matched in between paths.conf and httpd.conf: paths.conf. Use correct value for file_conf_mime_types
    • 1.0-130-EA-7383: Ensure 009-phpconf.pl (yum hook) never automagically sets handlers to “None”: never automatically set to none
  • ea-cpanel-tools
    • 1.0-18-EA-7173: DEV: Create recommendation for EOL PHP Versions:  Add URL field.
    • 1.0-18-EA-7173: DEV: Create recommendation for EOL PHP Versions:  Add recommendation for EOL PHPs

2018-5-22

  • libcurl
    • ZC-3769: Update cURL to 7.60.0, drop 7.59.0 (with fixes for CVE-2018-1000300 and CVE-2018-1000301)

2018-5-1

  • scl-php54-pear
    • 1.10.1-12-ZC-3484 : Create symlinks in /usr/bin for ea-php##-pear and ea-php##-pecl

  • scl-php55-pear
    • 1.10.1-12-ZC-3484 : Create symlinks in /usr/bin for ea-php##-pear and ea-php##-pecl
  • scl-php56-pear
    • 1.10.1-12-ZC-3484 : Create symlinks in /usr/bin for ea-php##-pear and ea-php##-pecl
  • scl-php70-pear
    • 1.10.1-12-ZC-3484 : Create symlinks in /usr/bin for ea-php##-pear and ea-php##-pecl
  • scl-php71-pear
    • 1.10.1-12-ZC-3484 : Create symlinks in /usr/bin for ea-php##-pear and ea-php##-pecl
  • scl-php72-pear
    • 1.10.1-12-ZC-3484 : Create symlinks in /usr/bin for ea-php##-pear and ea-php##-pecl
  • scl-php56
    • 5.6.36-1-EA-7435: Updated to version 5.6.36 via update_pkg.pl (EA-7435)

  • scl-php56-meta

    • 5.6.36-1-EA-7435: Updated to version 5.6.36 via update_pkg.pl (EA-7435)

  • scl-php70
    • 7.0.30-1-EA-7426: Updated to version 7.0.30 via update_pkg.pl (EA-7426)

  • scl-php70-meta
    • 7.0.30-1-EA-7426:  Updated to version 7.0.30 via update_pkg.pl (EA-7426)

  • scl-php71
    • 7.1.17-1-EA-7422: Updated to version 7.1.17 via update_pkg.pl (EA-7422)

  • scl-php71-meta

    • 7.1.17-1-EA-7430: Updated to version 7.1.17 via update_pkg.pl (EA-7422)

  • scl-php72

    • 7.2.5-1-EA-7430: Updated to version 7.2.5 via update_pkg.pl (EA-7430)

  • scl-php72-meta

    • 7.2.5-1-EA-7430: Updated to version 7.2.5 via update_pkg.pl (EA-7430)

2018-4-24

  • apr - 1.6.3-2

    • EA-7382: Update dependency on ea-openssl to require the latest version with versioned symbols

  • apr-util - 1.6.1-4

    • EA-7382: Update dependency on ea-openssl to require the latest version with versioned symbols

  • ea-apache2 - 2.4.33-5

    • EA-7382: Update dependency on ea-openssl to require the latest version with versioned symbols

  • libcurl - 7.59.0-2 

    • ZC-3626: Re-enable SFTP support via libssh2

    • EA-7382: Update dependency on ea-openssl to require the latest version with versioned symbols

  • ea-openssl - 1.0.2o-2

    • EA-7382: Ensure we build shared objects with versioned symbols.

    • EA-7382: Applied patch for CVE-2018-0737: Cache timing vulnerability in RSA Key Generation

  • ea-apache24-mod_cpanel - 1.1-1
    • EA-7387: Avoid segfaults when used with threaded MPMs.

  • mod_security2 - 2.9.2-9

    • EA-7382: Update dependency on ea-libcurl to require the latest version with versioned symbols

  • ea-freetds - 1.00.27-9

    • EA-7382: Update dependency on ea-openssl to require the latest version with versioned symbols

  • scl-libc-client - 2007f-13

    • EA-7382: Update dependency on ea-openssl to require the latest version with versioned symbols

  • scl-php54 - 5.4.45-54

    • ZC-3600: Update litespeed to the latest version (7.1).

    • EA-7382: Update dependency on ea-openssl to require the latest version with versioned symbols

  • scl-php55 - 5.5.38-37

    • ZC-3601: Update litespeed to the latest version (7.1).

    • EA-7382: Update dependency on ea-openssl to require the latest version with versioned symbols

  • scl-php56 - 5.6.35-3

    • ZC-3602: Update litespeed to the latest version (7.1).

    • EA-7382: Update dependency on ea-openssl to require the latest version with versioned symbols

  • scl-php70 - 7.0.29-3

    • ZC-3603: Update litespeed to the latest version (7.1).

    • EA-7382: Update dependency on ea-openssl to require the latest version with versioned symbols 

  • scl-php71 - 7.1.16-3

    • ZC-3604: Update litespeed to the latest version (7.1).

    • EA-7382: Update dependency on ea-openssl to require the latest version with versioned symbols

  • scl-php72 - 7.2.4-3

    • ZC-3605: Update litespeed to the latest version (7.1).

    • EA-7382: Update dependency on ea-openssl to require the latest version with versioned symbols

  • scl-ruby24-meta - 2.4.3-9

    • EA-7382: Update dependency on ea-openssl to require the latest version with versioned symbols

  • scl-ruby24-passenger - 5.1.8-5

    • EA-7382: Update dependency on ea-openssl to require the latest version with versioned symbols

2018-4-5

  • apr-util
    • 1.6.1-2 - EA-7360: Link against ea-openssl explicitly

  • ea-apache2
    • 2.4.33-4 - EA-7376: Ensure that mod_http2 is properly linked against ea-openssl.

    • 2.4.33-3 - EA-7367: Ensure that the tools are properly linked against ea-openssl.

  • ea-apache2-config
    • 1.0-128 - EA-7370: Have PHP config hook script error out if all PHPs would be set to `none`

2018-4-3

  • apr

    • 1.6.3-1 - EA-7242: Update to 1.6.3

    • 1.5.3-9 - ZC-3552: Version ea-openssl requirements
  • apr-util
    • 1.6.1-1 - EA-7243: Update to 1.6.1

    • 1.5.2-15 - ZC-3552: Adjusted for ea-openssl versioning and fixup

    • 1.5.2-14 - ZC-3460: build apr-util against our ea-openssl
  • ea-apache2

    • 2.4.33-1 - EA-7327: Update to 2.4.33, drop 2.4.29

    • 2.4.29-12 - EA-7339: Build against the latest apr/apr-util
    • 2.4.29-11 - EA-7164: Build mod_brotli against the ea-brotli package.
    • 2.4.29-10 - ZC-3401: Ensure building against and using ea-openssl

  • ea-apache2-config
    • 1.0-127 - EA-7252: Update migrate_extension_to_pecl_ini to use new INI file name

  • ea-brotli
    • 1.0.2-3 - ZC-3552: Ensure lib64 symlink is configured.

  • ea-freetds
    • 1.00.27-8 - ZC-3552: Added versioning to ea-openssl requirements.

    • 1.00.27-7 - ZC-3476: Update for ea-openssl shared object

  • ea-nghttp2
    • 1.20.0-8 - ZC-3552: Added versioning to ea-openssl requirements.

  • ea-openssl
    • 1.0.2o-1 - EA-7333: Update ea-openssl from 1.0.2n to 1.0.2o

    • 1.0.2n-3 - EA-7327: Added further configuration for shared openssl.

    • 1.0.2n-2 - ZC-3456: Adjust ea-openssl to build shared.

  • ea-tomcat85
    • 8.5.24-2 - EA-7297: Fix rpmlint errors and warnings

    • 8.5.24-1 - ZC-3244: Initial ea-tomcat85 (v8.5.24)

  • libcurl
    • 7.59.0-1 - EA-7336: Update cURL from 7.58.0 to 7.59.0

    • 7.58.0-5 - ZC-3552: Ensure curl is linked again ea-openssl, and ea-nghttp2 Additionally, added support for brotli. Added versioning to ea-openssl and nghttp2 requirements for easier maintenance.

    • 7.58.0-4 - ZC-3479: Ensure we only link only against our ea-openssl

  • modsecurity2
    • 2.9.2-8 - ZC-3552: Add versioning for ea-libcurl requirements

    • 2.9.2-7 - EA-7263: Do not generate SecHashKey when SecHashEngine isn’t on

  • scl-ioncube10
    • 10.2.0-1 - EA-7313: Update from 10.1.1 to 10.2.0

    • 10.1.1-1 - EA-7250: Update to 10.1.1,  drop 10.1.0

  • scl-libc-client
    • 2007f-12

      • ZC-3552: Added versioning to ea-openssl requirements.

      • ZC-3552: Linked to shared openssl .so's.

      • ZC-3552: Whitespace clean up.

  • scl-phalcon
    • 3.2.2-2 - EA-7253: Correct permissions on the Phalcon INI

  • scl-php-pear
    • 1.10.1-11 - EA-7252: Load PECL ini after PHP ini so that expected symbols will be available

  • scl-php54
    • 5.4.45-52 - ZC-3552: Added versioning to ea-openssl and ea-libcurl requirements.

    • 5.4.45-51 - ZC-3475: Update for ea-openssl shared object

  • scl-php55
    • 5.5.38-35 - ZC-3552: Added versioning to ea-openssl and ea-libcurl requirements.

    • 5.5.38-34 - ZC-3475: Update for ea-openssl shared object

  • scl-php56
    • 5.6.35-1 - EA-7355: Update to 5.6.35, drop 5.6.34

    • 5.6.34-3 - ZC-3552: Added versioning to ea-openssl and ea-libcurl requirements.

    • 5.6.34-2 - ZC-3475: Update for ea-openssl shared object

  • scl-php56-meta
    • 5.6.35-1 - EA-7355: Update to 5.6.35, drop 5.6.34

  • scl-php70
    • 7.0.29-1 - EA-7347: Update to 7.0.29, drop 7.0.28

    • 7.0.28-3 - ZC-3552: Added versioning to ea-openssl and ea-libcurl requirements.

    • 7.0.28-2 - ZC-3475: Update for ea-openssl shared object

  • scl-php70-meta
    • 7.0.29-1 - EA-7347: Update to 7.0.29, drop 7.0.28

  • scl-php71
    • 7.1.16-1 - EA-7351: Update to 7.1.16, drop 7.1.15

    • 7.1.15-3 - ZC-3552: Added versioning to ea-openssl and ea-libcurl requirements.

    • 7.1.15-2 - ZC-3475: Update for ea-openssl shared object

  • scl-php71-meta
    • 7.1.16-1 - EA-7351: Update to 7.1.16, drop 7.1.15

  • scl-php72
    • 7.2.4-1 - EA-7343: Update to 7.2.4, drop 7.2.3

    • 7.2.3-3 - ZC-3552: Added versioning to ea-openssl and ea-libcurl requirements.

    • 7.2.3-2 - ZC-3475: Update for ea-openssl shared object

  • scl-php72-meta

    • 7.2.4-1 - EA-7343: Update to v7.2.4, drop v7.2.3

  • scl-ruby24
    • 2.4.3-8 - EA-7341: Ensure we build against ea-openssl, and require the latest ea-ruby24-runtime pkg.

    • 2.4.3-7 - ZC-3402: Update for ea-openssl shared object

  • scl-ruby24-meta
    • 2.4.3-2 - EA-7341: Add ea-openssl to the LD_LIBRARY_PATH to ensure ruby can find the openssl libs.

  • scl-ruby24-passenger
    • 5.1.8-4 - EA-7341: Ensure passenger compiles against ea-openssl and ea-libcurl

    • 5.1.8-3 - ZC-3402: Update for ea-openssl shared object

2018-3-21

  • ea-apache24-mod_cpanel
    • 1.0-1 - EA-7191: Initial implementation of mod_cpanel: Handle requests to suspended users in apache without requiring an include file to be generated on the product side.

2018-3-6

  • ea-apache2
    • 2.4.29-9 - EA-7238: use documented and ea3 parity safe suexec_log path
    • 2.4.29-8 - EA-7217: Make sure we use ea-nghttp2
  • ea-brotli
    • 1.0.2-2 - EA-7223: fix typo in URL
  • ea-nghttp2
    • 1.20.0-7 - ZC-3365: move to /opt
  • libcurl
    • 7.58.0-3 - EA-7233: Require the newer version of ea-nghttp2 to ensure that the packages are updated as a set.
    • 7.58.0-2 - EA-7219: Build curl against the ea-nghttp2 that is installed in /opt/cpanel/nghttp2 to ensure that http2 can still be utilized.
  • scl-php54-meta
    • 5.4.45-20 - EA-5277: Add conflicts for ea-php##-scldevel packages
  • scl-php55-meta
    • 5.5.38-6 - EA-5277: Add conflicts for ea-php##-scldevel packages
  • scl-php56
    • 5.6.34-1 - EA-7268: Updated to version 5.6.34 via update_pkg.pl
  • scl-php56-meta
    • 5.6.34-1 - EA-7268: Update to v5.6.34, drop v5.6.33
    • 5.6.33-5 - EA-5277: Add conflicts for ea-php##-scldevel packages
  • scl-php70
    • 7.0.28-1 - EA-7272: Updated to version 7.0.28 via update_pkg.pl
  • scl-php70-meta
    • 7.0.28-1 - EA-7272: Update to v7.0.28, drop v7.0.27
    • 7.0.27-5 - EA-5277: Add conflicts for ea-php##-scldevel packages
  • scl-php71
    • 7.1.15-1 - EA-7264: Updated to version 7.1.15 via update_pkg.pl
  • scl-php71-meta
    • 7.1.15-1 - EA-7264: Update to v7.1.15, drop v7.1.14
    • 7.1.14-2 - EA-5277: Add conflicts for ea-php##-scldevel packages
  • scl-php72
    • 7.2.3-1 - EA-7289: Updated to version 7.2.3 via update_pkg.pl
  • scl-php72-meta
    • 7.2.3-1 - EA-7289: Update to v7.2.3, drop v7.2.2
    • 7.2.2-2 - EA-5277: Add conflicts for ea-php##-scldevel packages

2018-2-8

  • ea-apache2-config
    • 1.0-126 - ZC-3381: Ensure there is a newline after SSL hostname `</VirtualHost>`

  • ea-brotli
    • 1.0.2-1 - EA-7154: Initial brotli library for EA4

2018-2-6

  • ea-libxml2
    • 2.9.7-3 - EA-7135: Add root path to %files and Ensure ownership of _licensedir if it is set

  • libmcrypt
    • 2.5.8-5 - EA-7136: Add root path to %files and Ensure ownership of %{_docdir}

  • scl-ruby24
    • 2.4.3-6 - EA-7188: Update Ruby to 2.4.3

  • scl-php71
    • 7.1.14-1 - EA-7204: Updated to version 7.1.14 via update_pkg.pl

  • scl-php71-meta
    • 7.1.14-1 - EA-7204: Updated to version 7.1.14 via update_pkg.pl

  • scl-php72
    • 7.2.2-1 - EA-7208: Updated to version 7.2.2 via update_pkg.pl

  • scl-php72-meta
    • 7.2.2-1 - EA-7208: Updated to version 7.2.2 via update_pkg.pl

2018-1-30

  • ea-apache2
    • 2.4.29-7 - EA-7159: Use 'elinks' instead of 'links' as a dependency to ensure that EA4 does not pull packages from the EPEL repos

  • ea-nghttp2
    • 1.20.0-6 - EA-7197: Remove conflict for libnghttp2 until issues it causes with PHP curl are resolved

2018-1-29

  • ea-nghttp2
    • 1.20.0-5 EA-6555: add conflict for libnghttp2

    • 1.20.0-4 - EA-6638: bump release prefix to make the EA4 version newer than the typo'd-release-prefix in EA4-experimental

2018-1-26

  • scl-libc-client
    • 2007f-11 - EA-7182: Build against ea-openssl to ensure that any IMAP ssl calls made via PHP are functional.

2018-1-25

  • ea-libcurl
    • 7.58.0-1 - EA-7157: Update cURL to 7.58.0

  • ea-php56
    • 5.6.33-6 - EA-6990: Fix opcache.blacklist_filename value

2018-1-24

  • ea-libxml2
    • 2.9.7-2 - EA-7145: Remove incorrect Provides for libxml2

  • scl-php54
  • 5.4.45-50 - HB-3287: Increase open file limit for php-fpm by default

  • scl-php54-meta
    • 5.4.45-19 - EA-6958: Ensure ownership of _licensedir if it is set

    • 5.4.45-18 - ZC-3247: Add support for the allowed-php list

  • scl-php55
    • 5.5.38-33 - HB-3287: Increase open file limit for php-fpm by default

  • scl-php55-meta
    • 5.5.38-5 - EA-6958: Ensure ownership of _licensedir if it is set

    • 5.5.38-4 - ZC-3247: Add support for the allowed-php list

  • scl-php56
    • 5.6.33-5 - HB-3287: Increase open file limit for php-fpm by default

  • scl-php56-meta

    • 5.6.33-4 - EA-6958: Ensure ownership of _licensedir if it is set

    • 5.6.33-3 - ZC-3247: Add support for the allowed-php list 

  • scl-php70
    • 7.0.27-5 - HB-3287: Increase open file limit for php-fpm by default

  • scl-php70-meta
    • 7.0.27-4 - EA-6958: Ensure ownership of _licensedir if it is set

    • 7.0.27-3 - ZC-3247: Add support for the allowed-php list

  • scl-php71
    • 7.1.13-5 - HB-3287: Increase open file limit for php-fpm by default

  • scl-php71-meta
    • 7.1.13-4 - EA-6958: Ensure ownership of _licensedir if it is set

    • 7.1.13-3 - ZC-3247: Add support for the allowed-php list 

  • scl-php72
    • 7.2.1-5 - HB-3287: Increase open file limit for php-fpm by default

  • scl-php72-meta
    • 7.2.1-4 - EA-6958: Ensure ownership of _licensedir if it is set

    • 7.2.1-3 - ZC-3247: Add support for the allowed-php list 

2018-1-18

  • ea-apache2

    • 2.4.29-6 - EA-7125: Remove previous piped logging patch

    • 2.4.29-5 - EA-7127: Ensure the mod_proxy_html and mod_xml2enc modules build against ea-libxml2. Additionally, updated the build process to avoid modifying the LDFLAGS - as it caused the libxml2 dependency to be carried to extensions compiled separately.

    • 2.4.29-4 - EA-7060: Supress Long Lost Pids warning

    • 2.4.29-3 - EA-7044: Adjust Apache to use ea-libxml2

    • 2.4.29-2 - EA-6020: Restarting Apache while using splitlogs can result in "Broken pipe" errors 

      • - Apply patch provided by Gary Stanley

  • ea-apache2-config
    • 1.0-125 - ZC-3249: Ensure the "default SSL" vhost is properly bound to all of the shared IPs on the server. Additionally, fixed up the whitespace oddities in the generated vhost.

  • ea-libxml2
    • 2.9.7-4 - EA-7043: Update from v2.9.4 to v2.9.7

      • fixed %setup so that we do not need to modify tarball (EA-6094)

      • remove unreferenced 2.9.4-remove-pyverify_fd patch

      • Add Provides of libxml2

  • ea-openssl
    • 1.0.2n-1 - EA-7086: Update ea-openssl from 1.0.2m to 1.0.2n for CVE-2017-3737

  • mod_security2
    • 2.9.2-6 - EA-7098: fix rpath to allow to build against ea-libxml2 libs

    • 2.9.2-5 - EA-7044: Adjust mod_security to use ea-libxml2

  • scl-php54
    • 5.4.45-49 - HB-3263: Ensure securetmp is done before starting FPM

    • 5.4.45-48 - EA-7044: Adjust PHPs to use ea-libxml2

    • 5.4.45-47 - HB-3061: Fix epoll bug
  • scl-php54-meta
    • 5.4.45-17 - ZC-3242: Ensure the runtime package requires the meta package

  • scl-php55
    • 5.5.38-32 - HB-3263: Ensure securetmp is done before starting FPM

    • 5.5.38-31 - EA-7044: Adjust PHPs to use ea-libxml2

    • 5.5.38-30 - HB-3061: Fix epoll bug.

  • scl-php55-meta
    • 5.5.38-3 - ZC-3242: Ensure the runtime package requires the meta package

  • scl-php56
    • 5.6.33-4 - HB-3263: Ensure securetmp is done before starting FPM

    • 5.6.33-3 - EA-7044: Adjust PHPs to use ea-libxml2

    • 5.6.33-2 - HB-3061: Fix epoll bug.

  • scl-php56-meta
    • 5.6.33-2 - ZC-3242: Ensure the runtime package requires the meta package

  • scl-php70

    • 7.0.27-4 - HB-3263: Ensure securetmp is done before starting FPM

    • 7.0.27-3 - EA-7044: Adjust PHPs to use ea-libxml2

    • 7.0.27-2 - HB-3061: Fix epoll bug.
  • scl-php70-meta
    • 7.0.27-2 - ZC-3242: Ensure the runtime package requires the meta package

  • scl-php71
    • 7.1.13-4 - HB-3263: Ensure securetmp is done before starting FPM

    • 7.1.13-3 - EA-7044: Adjust PHPs to use ea-libxml2

    • 7.1.13-2 - HB-3061: Fix epoll bug.
  • scl-php71-meta
    • 7.1.13-2 - ZC-3242: Ensure the runtime package requires the meta package

  • scl-php72
    • 7.2.1-4 - HB-3263: Ensure securetmp is done before starting FPM

    • 7.2.1-3 - EA-7044: Adjust PHPs to use ea-libxml2

    • 7.2.1-2 - HB-3061: Fix epoll bug.
  • scl-php72-meta
    • 7.2.1-2 - ZC-3242: Ensure the runtime package requires the meta package

2018-1-9

  • ea-apache2-config
    • 1.0-124 - EA-6668: Update ea4_main.default to handle hostname SSL && Update IPs list to only be a wildcard for hostname SSL

  • scl-php56
    • 5.6.33-1 - EA-7083: Update PHP 5.6 to version 5.6.33 via update_pkg.pl, drop 5.6.32

  • scl-php56-meta
    • 5.6.33-1 - EA-7084: Update PHP 5.6 to version 5.6.33 via update_pkg.pl, drop 5.6.32

  • scl-php70
    • 7.0.27-1 - EA-7078: Update PHP 7.0 to version 7.0.27 via update_pkg.pl, drop 7.0.26

  • scl-php70-meta
    • 7.0.27-1 - EA-7079: Update PHP 7.0 to version 7.0.27 via update_pkg.pl, drop 7.0.26

  • scl-php71

    • 7.1.13-1 - EA-7070: Update PHP 7.1 to version 7.1.13 via update_pkg.pl, drop 7.1.12

  • scl-php71-meta
    • 7.1.13-1 - EA-7071: Update PHP 7.1 to version 7.1.13 via update_pkg.pl, drop 7.1.12

  • scl-php72
    • 7.2.1-1 - EA-7074: Update PHP 7.2 to version 7.2.1 via update_pkg.pl,  drop 7.2.0

  • scl-php72-meta
    • 7.2.1-1 - EA-7075: Update PHP 7.2 to version 7.2.1, drop 7.2.0