Automatic MySQL® Upgrade Information Center


Last modified: September 24, 2020

Overview

Due to various support and security reasons, cPanel, L.L.C. will automatically upgrade any customer servers that run MySQL® 5.5 to MySQL 5.7. We plan to perform this upgrade in 2021.

We strongly encourage you to upgrade MySQL to a supported version of MySQL or MariaDB® before the automatic upgrade.

This document contains information to explain why cPanel, L.L.C. is doing this, how it can impact you, and what you need to do to ensure success or minimize downtime.

Why is cPanel, L.L.C. doing this?

It is our policy to block upgrades for various reasons, such as new memory requirements or new code that does not support deprecated software. You can read more about our deprecation plan and policy in our cPanel Deprecation Plan documentation.

We added a block that prevented servers that run MySQL 5.5 from upgrading to cPanel & WHM version 80. Because of this, many customers still ran MySQL 5.5 on cPanel & WHM version 78.

We recently changed this block so that servers that run MySQL 5.5 can now upgrade from cPanel & WHM version 78 to version 86. We will also allow those servers to upgrade to cPanel & WHM version 92.

What if you stay on older software?

If a customer continues to use an older version of software, whether MySQL or cPanel & WHM, they will encounter issues such as (but not limited to) the following:

  • Components of their server may run deprecated or end-of-life versions.

  • cPanel, L.L.C. does not support end-of-life software. MySQL 5.5 reached end-of-life status in December 2018 and cPanel & WHM version 78 reached end-of-life status in the first quarter of 2020. cPanel & WHM version 86 will reach end-of-life status in the first quarter of 2021.

  • Compatibility issues with other software components or third-party software, such as WordPress®.

  • Missing new features in cPanel & WHM that competitors provide.

  • Security issues, which will not receive patches because the software has reached end-of-life status.

For example, in early 2019, many customers’ servers contained a dangerous vulnerability in outdated and unsupported versions of EXIM. This urgent problem caused a lot of issues for customers.

By proactively upgrading MySQL to supported versions, we can ensure that customers run supported software to avoid a similar scenario.

How cPanel, L.L.C. is notifying you of this automatic upgrade

We are notifying you of this automatic upgrade through the following methods:

  • A large banner in the WHM interface about the deprecated MySQL database that links to WHM’s MySQL or MariaDB Upgrade interface (WHM >> Home >> SQL Services >> MySQL/MariaDB Upgrade).

  • Multiple notifications through WHM’s Contact Manager.

  • A blog post about the automatic update.

  • The cPanel Deprecation Plan document.

  • An email from cPanel, L.L.C. to all current users of MySQL 5.5.

  • An announcement on the cpanel.net website.

  • Surveys that ask customers and partners why they still run MySQL 5 and what concerns they have regarding upgrades to newer version, whether self-managed or automatic.

  • This document.

The Contact Manager notifications will include a 30-day countdown to the day of automatic upgrades.

How to upgrade MySQL before the automatic upgrade

We strongly recommend that you or your managed hosting provider upgrade MySQL as soon as possible. This can help you to avoid unexpected database incompatibility or corruption.

To upgrade your server, perform the following steps:

  1. Investigate all applications that run on your server which require database services for potential compatibility issues with the new MySQL version. For example, older versions of WordPress®.

  2. Schedule a maintenance window and inform your customers.

  3. Back up the affected cPanel & WHM servers. You can perform these backups via WHM’s Backup Configuration interface (WHM >> Home >> Backup >> Backup Configuration) or through the command line.

  4. Perform the upgrade through WHM’s MySQL or MariaDB Upgrade interface (WHM >> Home >> SQL Services >> MySQL/MariaDB Upgrade) or through the WHM API 1 start_background_mysql_upgrade function.

  5. Test your applications to ensure that they function properly.

If you require assistance with any issues as a result of this upgrade, you can either hire an experienced system administrator or submit a ticket through our Customer Support Portal.

We provide a listing of experienced system administrators in our forums.

What the automatic upgrade will do

All servers that run cPanel & WHM version 78 will receive an update that includes the MySQL upgrade patch.

First phase

In the first phase up upgrades, servers that meet the following attributes will schedule the upgrade from MySQL 5.5 to MySQL 5.7:

  • The local MySQL server runs version 5.5.

  • The local cPanel & WHM server runs version 78.

  • No databases exist on the server.

For 30 days, these servers will notify the administrator through WHM’s Contact Manager that MySQL 5.5 will automatically upgrade.

After the 30 day notification window ends, these servers will automatically perform the upgrade from MySQL 5.5 to MySQL 5.7. Then, the server will send the administrator a success or failure message.

Second phase

Important:
We are still researching the possibility of a second phase of automatic upgrades.

In the second phase of upgrades, servers that meet the following attributes will schedule the upgrade from MySQL 5.5 to MySQL 5.7:

  • The local MySQL server runs version 5.5.

  • The local cPanel & WHM server runs version 78.

  • A small number of databases exist on the server.

  • The databases that exist on the server are small.

  • A small number of database users exist on the server.

  • The my.cnf file is a standard configuration and does not contain any customization.

  • No database corruption detected.

How will this automatic upgrade impact you?

The automatic upgrade can potentially impact customers in the following ways:

  • If database corruption exists, and the MySQL version upgrade cannot detect it before upgrading, then the upgrade will cause a worse state for database services. This will likely to cause websites to break.

  • If a large number of databases or large databases exist on the server, then the MySQL version upgrade could take a long time. This will cause an extended period of website downtime during this process.

  • If the server uses third-party party software that relies on database services and they are incompatible with the new version of MySQL, then the MySQL version upgrade will break these plugins.

  • If your server uses the old MySQL 5.1 password format, database users must update their passwords after the MySQL version upgrade.

cPanel, L.L.C. will not be monitoring individual MySQL upgrade failures, so we will not know if you need assistance until you submit a technical support ticket. This may result in extended downtime for your server.

Webinar demonstrations

cPanel, L.L.C. hosted a webinar on Monday December 30, 2019 that demonstrated the upgrade process.

You can watch a recording of the webinar on the cPanel YouTube channel.

We will post a recording of that webinar afterwards.

Backup and restoration

Backup

To back up databases for each account, use WHM’s Backup Configuration interface (WHM >> Home >> Backup >> Backup Configuration).

The backup will exist in the location that you set under the Configure Backup Directory section.

For more information about backup and recovery, read MySQL’s Backup and Recovery article and the How do I back up MySQL databases prior to upgrading to a new version? tutorial in our forums.

Restoration

You can use WHM’s Backup Restoration feature (WHM >> Home >> Backup >> Backup Restoration) to restore an individual account and its database contents.

For more information about backup and recovery, read MySQL’s Backup and Recovery article.

Frequently asked questions

Where is the guide to update cPanel MySQL?

Read our MySQL or MariaDB Upgrade documentation.

The instructions are too complicated. I feel out of my depth.

We recommend that you hire an experienced system administrator to perform the upgrade for you. We provide a listing of experienced system administrators in our forums.

You can also watch our webinar to familiarize yourself with the process.

How do I do this for Remote MySQL setup?

If the remote server runs cPanel & WHM, you can use WHM’s MySQL or MariaDB Upgrade interface (WHM >> Home >> SQL Services >> MySQL/MariaDB Upgrade) or use the WHM API 1 start_background_mysql_upgrade function on the remote server.

If the remote server uses another platform, read and follow the upgrade instructions for that platform.

Is updating MySQL important? Why should I do this?

If a server continues to run an older version of our software, it will encounter issues such as (but not limited to) the following:

  • cPanel, L.L.C. does not support end-of-life software.

  • Compatibility issues with other software components.

  • Security issues and vulnerabilities.

Is updating MySQL mandatory? How long can I keep MySQL 5.5? 5.6?

In extreme cases, you can disable all updates and keep your existing software. However, you will no longer receive support from cPanel, L.L.C. and will expose your server to potential security issues and vulnerabilities.

We strongly discourage you from doing this.

I have MySQL 5.5. Is it advisable to go to MariaDB 10.3 instead of MySQL 5.7?

MariaDB 10.3 contains several significant differences from MySQL 5.7. For a list of differences, read MariaDB’s Incompatibilities and Feature Differences Between MariaDB 10.3 and MySQL 5.7 knowledge base article.

If you do not require any of the affected features, then you should be able to upgrade to MariaDB 10.3. However, cPanel & WHM does not support migrations from MariaDB back to MySQL.

Can I just upgrade to MySQL 5.6?

Yes, you can. However, MySQL 5.6 reaches end-of-life on February 5, 2021.

MySQL 5.7 offers significant performance enhancements and active support. For a list of differences between MySQL 5.5 and 5.7, read MySQL’s What Is New in MySQL 5.7 document.

Can I just wait to upgrade my whole server to CentOS 8 and MySQL 8.0 when cPanel & WHM support for CentOS 8 is no longer experimental?

Yes, you can. Until you do, you still run the risks of using unsupported versions of MySQL 5.5 and cPanel & WHM.

I want to jump more than one version ahead. Do I have to upgrade to 5.6 first?

No, because the system actually performs stepped upgrades as part of the upgrade process. So, all you need to do is start the upgrade from MySQL 5.5 to MySQL 5.7.

Would the update be safe for me to do within WHM without a sysadmin?

We have simplified the upgrade process as much as possible, but you may encounter an unexpected issue. If you have an experienced system administrator or database administrator available during the conversion, they can resolve problems for you quickly and mitigate service interruptions for your customers. This is preferable to searching for a system administrator or database administrator while your customers are calling and emailing you about the server.

How do I revert to my previous MySQL version if there is a problem?

Both cPanel, L.L.C. and MySQL recommend against downgrading or rolling back MySQL, and we do not support downgrades.

Will this alter the appearance of my website?

If your website uses software that is compatible with the new database version, no.

Will this affect current email services production or Exim services?

Standard email services through Exim and Dovecot do not depend on MySQL services. However, if you have an email application that uses MySQL, such as a database-driven mail service, then it will not be available during the upgrade window.

Will I lose files?

No, the upgrade process will not alter any files on your server’s accounts.

Will I lose data?

No, the upgrade process will not lose any data from the databases. However, if your application software uses deprecated or removed commands, you may not be able to access that data.

We recommend that you upgrade any software that depends on these databases to use the latest command sets.

Will this break accounts?

No, the upgrade process will not break cPanel accounts on your server.

How do I check my configuration settings to know if there will be a problem during or after the upgrade?

Check the MySQL upgrade log on your server to determine if there were any issues during the upgrade.

The log files exist in the /var/cpanel/logs/mysql_upgrade_log.YYYYMMDD-hhmmss directory, which uses the following format:

  • YYYY — Four-digit year.
  • MM — Two-digit month.
  • DD — Two-digit day.
  • hh — Two-digit hour.
  • mm — Two-digit minute.
  • ss — Two-digit second.

Will this cause site downtime? Will this break my sites?

The upgrade will cause downtime. We strongly recommend that you schedule a maintenance window and inform your customers when the upgrade is being performed.

Will this stop services? Will it restart services?

The server will stop the MYSQL service before performing the upgrade. If your site depends on MySQL data, then your site will be unavailable during this time.

Will this cause the SQL server to stop working?

Only during the upgrade or if it encounters a problem during the upgrade.

If I go from MySQL to MariaDB, will all databases be automatically imported or do I need to export the .sql files from all sites? What happens to existing databases?

If you migrate from MySQL to MariaDB, your cPanel & WHM server will automatically migrate the database contents and users to the new platform.

Will existing applications and their databases be affected by this upgrade? If so, what precautions should I take?

You will need to read the documentation for your applications to confirm compatibility with the new version of MySQL.

As for precautions, we strongly recommend that you back up your server data in case of corruption or incompatibility.

In Step 2, what does the critical warning for Strict Mode mean?

A MySQL server in Strict Mode will reject data change statements that contain invalid or missing values. If Strict Mode is off, MySQL will insert adjusted values for these invalid or missing values and then return a warning.

For more information about Strict Mode, read MySQL’s Strict SQL Mode article.

Check your software’s documentation and system requirements to confirm that they are compatible with Strict Mode.

For example, the current version of WordPress is compatible with both MySQL 5.6 or greater as well as MariaDB version 10.1 or greater. This includes Strict Mode.

Is it safe to check all of the boxes in Step 2 of the interface?

You must check all of the boxes on Step 2 of the interface to proceed with the upgrade.

In Step 3, should I choose interactive or unattended upgrade?

If you are or have access to an experienced database administrator, then you should chose interactive. Otherwise, you should choose unattended.

How do I perform a repair of my current DB?

For information on how to repair a database, read A2hosting’s Repairing MySQL Databases and tables article.

Additional Documentation