Overview

The mod_fcgid Apache module provides an alternative module to the mod_cgi Apache module. 

Usage

  • You cannot use the FastCGI daemon (FCGId) with MultiPHP prior to cPanel & WHM version 74.
  • EasyApache 4 migrations only migrate FCGId on systems that run cPanel & WHM version 76. In earlier versions, you must install the Apache mod_fcgid module independently.
  • We only recommend the mod_fcgid Apache module for advanced system administrators who understand how to modify the module's performance.
  • On systems prior to cPanel & WHM version 78, if your default PHP version uses FCGId, then all PHP versions will use FCGId.

FCGId serves PHP applications through the mod_fcgid Apache module. This module launches multiple instances of a program to enable the system to handle multiple concurrent requests.  EasyApache 4 supports FCGId on system without a PHP-FPM implementation. 

Requirements

This module does not possess any requirements.

Compatibility

You can only use the mod_fcgid Apache module with cPanel & WHM version 62 or later. 

You cannot use the mod_fcgid Apache module with the following features:

How to install or uninstall mod_fcgid

In the interface

Install or uninstall the mod_fcgid Apache module with WHM's EasyApache 4 interface (WHM >> Home >> Software >> EasyApache 4)

On the command line

To install the mod_fcgid Apache module in EasyApache 4, run the following command:

yum install ea-apache24-mod_fcgid

To uninstall the mod_fcgid Apache module in EasyApache 4, run the following command:

 yum remove ea-apache24-mod_fcgid

Additional documentation