Overview

Hosting providers often prefer to standardize their software and application environment, which includes the deployed version of cPanel & WHM. Usually, a specific release tier (such as STABLE, RELEASE, or CURRENT) ensures a consistent environment across many servers.

In some circumstances, providers prefer not to rely on cPanel, Inc.'s tiered release system to select the installed version of cPanel & WHM. Additionally, providers who require a specific version of cPanel & WHM need an assured method to deploy new installations of cPanel & WHM, even when that version is no longer the current production release.  

The purpose of Long-Term Support

cPanel, Inc. actively develops cPanel & WHM, and we release new builds frequently. Traditionally, more conservative system administrators choose to completely disable software updates in order to maintain control over their deployments of cPanel & WHM. The Long-Term Support (LTS) tier provides an alternative to disabling updates, and will help ensure that cPanel & WHM servers receive important updates and fixes.

To view the cPanel & WHM version on each release tier, visit our httpupdate.cpanel.net site.

cPanel & WHM version 11.34 includes changes to Long-Term Support

The 11.34 release of cPanel & WHM introduces changes to the Long-Term Support tier.

Third-party applications

cPanel & WHM provides various third-party applications (for example, MySQL® and Roundcube).

cPanel, Inc. will continue to provide critical and security-related updates to these third-party applications when a customer installs them with an LTS version of cPanel & WHM. However, cPanel, Inc. may provide these fixes as back-ported patches instead of as upgrades to the latest version of the application. 

EasyApache

cPanel, Inc. develops and updates EasyApache with a separate release schedule from cPanel & WHM's release schedule.

cPanel, Inc. provides EasyApache updates for an LTS release until the LTS release reaches End of Life (EOL). If the currently-installed version of cPanel & WHM does not meet the requirements of a new EasyApache function or feature, EasyApache will update but the functionality is not guaranteed or supported. 

EasyApache 3 deprecation

Currently, EasyApache 3 is no longer in development and only receives security updates. EasyApache 3 is tentatively scheduled for deprecation at some point in 2018. You will receive at least three months notification prior to official deprecation. After that time, EasyApache 3 will no longer receive any updates. 

We strongly recommend that you upgrade to EasyApache 4. For more information, read our EasyApache 4 documentation. 

Site Software (cPAddons)

cPAddons in cPanel's Site Software interface (Home >> Software >> Site Software) continue to receive updated applications throughout the lifespan of an LTS release.

WHM Plugins

Plugins in WHM's Manage Plugins  interface (Home >> cPanel >> Manage Plugins) continue to receive updated applications throughout the lifespan of an LTS release.

Schedule for Long-Term Support releases of cPanel & WHM

Additional documentation