EasyApache 4 Change Log 2020


Last modified: May 21, 2020

EasyApache 4 does not use versioning and organizes changes by date only.

Each entry contains the following information:

  1. The package that we changed.
  2. The case number for the change.
  3. A description of the change.

For more information about our GitHub repository, read our The EasyApache 4 Git Repository and Build Updates documentation.

2020-5-21

  • ea-profiles-cpanel

    • EA-9045: Remove PHP 7.1 from the profiles since it is EOL.
  • scl-php72

    • EA-9067: Update scl-php72 to 7.2.31, drop 7.2.30 (with fix for CVE-2019-11048).
  • scl-php72-meta

    • EA-9067: Update scl-php72 to 7.2.31, drop 7.2.30 (with fix for CVE-2019-11048).
  • scl-php73

    • EA-9071: Revert new .user.ini search behavior.
    • EA-9068: Update scl-php73 to 7.3.18, drop 7.3.17 (with fix for CVE-2019-11048).
  • scl-php73-meta

    • EA-9068: Update scl-php73 to 7.3.18, drop 7.3.17 (with fix for CVE-2019-11048).
  • ea-php74

    • EA-9072: Revert new .user.ini search behavior.
    • EA-9070: Update ea-php74 to 7.4.6, drop 7.4.5 (with fix for CVE-2019-11048).
  • ea-php74-meta

    • EA-9070: Update ea-php74 to 7.4.6, drop 7.4.5 (with fix for CVE-2019-11048).
  • ea-tomcat85

    • EA-9060: Update ea-tomcat85 to 8.5.55, drop 8.5.54 (with fix for CVE-2020-9484).

2020-5-6

  • ea-apache2

    • EA-8809: Ensure that MAX_FD_LIMIT is not exceeded.
    • EA-9047: Update POSTRANS openssl rand calls removing not found /proc entries.
    • EA-9042: Do not install init.d/httpd files on C7 and above.
  • ea-oniguruma

    • ZC-6650: initial release.
  • ea-php74

    • ZC-6649: Re-enable multibyte regex for 7.4.
  • libcurl

    • EA-9044: Update libcurl to 7.70.0, drop 7.69.1.
  • scl-php-pear

    • EA-9050: Ensure autotools-latest-autoconf is also required by ea-php74.
  • scl-sourceguardian

    • ZC-6571: Add SourceGuardian for PHP 7.4.
    • Update scl-sourceguardian to 11.4.1, drop 11.3.4.

2020-4-29

  • ea-cpanel-tools

    • ZC-4935: Add recommendation for -php-cli and -php-common removal.
  • ea-php54-php-memcache

    • ZC-6608: Fix Requires for PHP.
  • ea-php54-php-memcached

    • ZC-6608: Fix Requires for PHP.
  • ea-php55-php-memcache

    • ZC-6608: Fix Requires for PHP.
  • ea-php55-php-memcached

    • ZC-6608: Fix Requires for PHP.
  • ea-php56-php-memcache

    • ZC-6608: Fix Requires for PHP.
  • ea-php56-php-memcached

    • ZC-6608: Fix Requires for PHP.
  • ea-php70-php-memcache

    • ZC-6608: Fix Requires for PHP.
  • ea-php70-php-memcached

    • ZC-6608: Fix Requires for PHP.
  • ea-php71-php-memcache

    • ZC-6608: Fix Requires for PHP.
  • ea-php71-php-memcached

    • ZC-6608: Fix Requires for PHP.
  • ea-php72-php-memcache

    • ZC-6608: Fix Requires for PHP.
  • ea-php72-php-memcache

    • ZC-6608: Fix Requires for PHP.
  • ea-php73-php-memcache

    • ZC-6608: Fix Requires for PHP.
  • ea-php73-php-memcached

    • ZC-6608: Fix Requires for PHP.
  • ea-php74-php-memcache

    • ZC-6608: Fix Requires for PHP.
  • ea-php74-php-memcached

    • ZC-6608: Fix Requires for PHP.
  • ea-profiles-cpanel

    • ZC-6297: Add ea-php74 to allphp and allphp-opcache profiles.

2020-4-23

  • ea-php74
    • EA-9014: JPEG support missing from PHP 7.4.

2020-4-22

  • ea-apache2

    • EA-9010: Patch apache 2.4.43 to fix ssl stapling memory leak.
  • ea-apache24-mod_lsapi

    • EA-8300: remove Provides from SPEC file to allow reinstalls.
  • ea-cpanel-tools

    • EA-8960: Update end-of-life PHP phrase.
  • ea-nodejs10

    • EA-9004: Update ea-nodejs10 to 10.20.1, drop 10.20.0.
  • ea-php74

    • EA-9007: Update ea-php74 to 7.4.5, drop 7.4.2 (with fix for CVE-2020-7067).
  • ea-php74-meta

    • EA-9007: Update ea-php74 to 7.4.5, drop 7.4.2 (with fix for CVE-2020-7067).
  • scl-php72

    • EA-9015: Update scl-php72 to 7.2.30, drop 7.2.29 (with fix for CVE-2020-7067).
  • scl-php72-meta

    • EA-9015: Update scl-php72 to 7.2.30, drop 7.2.29 (with fix for CVE-2020-7067).
  • scl-php73

    • EA-9009: Update scl-php73 to 7.3.17, drop 7.3.16 (with fix for CVE-2020-7067).
  • scl-php73-meta

    • EA-9009: Update scl-php73 to 7.3.17, drop 7.3.16 (with fix for CVE-2020-7067).
  • scl-ruby24-rubygem-rack

    • EA-9011: Update scl-ruby24-rubygem-rack to 2.2.2, drop 2.0.1.
  • ea-openssl11

    • EA-9017: Update ea-openssl11 to, 1.1.1g, drop 1.1.1f (with fix for CVE-2020-1967)
  • ea-tomcat85

    • EA-9008: Update ea-tomcat85 to 8.5.54, drop 8.5.53.

2020-4-15

  • ea-apache24-mod_lsapi
    • ZC-6114: Add ea-php74 to hardcoded list that rpm/switch_lsapi uses to build /etc/container/php.handler.
  • ea-cpanel-tools
    • EA-8930: Update max_execution_time default to 30.
  • ea-libicu
    • EA-8925: Add ea-libicu packages for PHP 7.4.
  • ea-liblsapi
    • ZC-6114: PHP 7.4 update.
  • ea-libzip
    • EA-8863: Add ea-libzip packages for PHP 7.4.
  • ea-nodejs10

    • EA-8985: Update ea-nodejs10 from 10.19.0 to 10.20.0.
  • ea-php54-php-memcache

    • EA-8978: Add PHP as a dependency.
    • ZC-6515: Promote from experimental.
  • ea-php55-php-memcache

    • EA-8978: Add PHP as a dependency.
    • ZC-6515: Promote from experimental.
  • ea-php56-php-memcache

    • EA-8978: Add PHP as a dependency.
    • ZC-6515: Promote from experimental.
  • ea-php54-php-memcached

    • EA-8978: Add PHP as a dependency.
    • ZC-6515: Promote from experimental.
    • EA-8224: Built with our ea-libmemcached module.
  • ea-php55-php-memcached

    • EA-8978: Add PHP as a dependency.
    • ZC-6515: Promote from experimental.
    • EA-8224: Built with our ea-libmemcached module.
  • ea-php56-php-memcached

    • EA-8978: Add PHP as a dependency.
    • ZC-6515: Promote from experimental.
    • EA-8224: Built with our ea-libmemcached module.
  • ea-php70-php-memcache

    • EA-8978: Add PHP as a dependency.
    • ZC-6515: Promote from experimental.
    • EA-8224: Updated to 4.0.3.
  • ea-php71-php-memcache

    • EA-8978: Add PHP as a dependency.
    • ZC-6515: Promote from experimental.
    • EA-8224: Updated to 4.0.3.
  • ea-php72-php-memcache

    • EA-8978: Add PHP as a dependency.
    • ZC-6515: Promote from experimental.
    • EA-8224: Updated to 4.0.3.
  • ea-php73-php-memcache

    • EA-8978: Add PHP as a dependency.
    • ZC-6515: Promote from experimental.
    • EA-8224: Updated to 4.0.3.
  • ea-php70-php-memcached

    • EA-8978: Add PHP as a dependency.
    • ZC-6515: Promote from experimental.
    • EA-8224: Updated to 3.1.3 from upstream and built with ea-libmemcached.
  • ea-php71-php-memcached

    • EA-8978: Add PHP as a dependency.
    • ZC-6515: Promote from experimental.
    • EA-8224: Updated to 3.1.3 from upstream and built with ea-libmemcached.
  • ea-php72-php-memcached

    • EA-8978: Add PHP as a dependency.
    • ZC-6515: Promote from experimental.
    • EA-8224: Updated to 3.1.3 from upstream and built with ea-libmemcached.
  • ea-php73-php-memcached

    • EA-8978: Add PHP as a dependency.
    • ZC-6515: Promote from experimental.
    • EA-8224: Updated to 3.1.3 from upstream and built with ea-libmemcached.
  • ea-php74-php-memcache

    • EA-8976: Add ea-php74-php-memcache(d) packages, initial release.
  • ea-php74-php-memcached

    • EA-8976: Add ea-php74-php-memcache(d) packages, initial release.
  • ea-php74

    • EA-8907: Add PHP 7.4, initial release.
  • ea-php74-meta

    • EA-8907: Add PHP 7.4, initial release.
  • libmemcached

    • EA-8979: Ensure the package owns /opt/cpanel/libmemcached.
    • ZC-6515: Promote from experimental.
    • EA-8224: Updated spec file from upstream and moved files to be under /opt/cpanel.
  • scl-php54-meta

    • ZC-6270: Fix circular dependencies.
  • scl-php55-meta

    • ZC-6270: Fix circular dependencies.
  • scl-php56-meta

    • ZC-6270: Fix circular dependencies.
  • scl-php70-meta

    • ZC-6270: Fix circular dependencies.
  • scl-php-pear

    • ZC-5915: Add PHP 7.4.
  • scl-libc-client

    • ZC-5915: Adding PHP 7.4.
  • scl-ruby24

  • scl-ruby24-meta

    • EA-8992: Update meta package to Ruby 2.4.10.

2020-4-8

  • ea-apache24
    • EA-8958: Update ea-apache2 to 2.4.43, drop 2.4.41.
  • scl-php56
    • EA-8963: Update scl-php56 libcurl version requirement to match the other PHPs.
  • ea-cpanel-tools
    • ZC-5894: Move PHP.ini directive data to RPM.

2020-4-2

  • ea-openssl11
    • EA-8961: Update ea-openssl11 to 1.1.1f, drop 1.1.1e.

2020-4-1

  • scl-ruby24-passenger

    • EA-8928: Updated the required version for ea-libcurl.
      • scl-php54
      • scl-php55
      • scl-php56
      • scl-php70
      • scl-php71
      • scl-php72
      • scl-php73
    • EA-8898: Update scl-ruby24-passenger to 6.0.4, drop 5.3.7.
  • mod_security2

    • EA-8928: Updated the required version for ea-libcurl.
  • libcurl

    • EA-8947: Update libcurl to 7.69.1, drop 7.68.0.
    • EA-8928: Added version check for libssh2.
  • ea-tomcat85

    • EA-8948: Update ea-tomcat85 to 8.5.53, drop 8.5.51.
  • ea-openssl11

    • EA-8946: Update ea-openssl11 to 1.1.1e, drop 1.1.1d (with fix for CVE-2019-1551).

2020-3-25

  • ea-apache2

    • EA-8786: Patch apxs to use the correct value for top_builddir.
    • EA-8927: Patch apache 2.4.x httpd for OCSP stapling bug.
    • EA-8876: Made ea-apache24 require ea-apache24-mod_headers.
  • ea-apache2-config

    • ZC-3620: Factor in non-global includes from the include editor.
  • scl-ioncube10

    • EA-8865: Add php-cli as a dependency.
  • scl-php72

    • EA-8931: Update scl-php72 to 7.2.29, drop 7.2.28.
  • scl-php72-meta

    • EA-8931: Update scl-php72 to 7.2.29, drop 7.2.28.
  • scl-php73

    • EA-8932: Update scl-php73 to 7.3.16, drop 7.3.15.
  • scl-php73-meta

    • EA-8932: Update scl-php73 to 7.3.16, drop 7.3.15.
  • scl-sourceguardian

    • EA-8865: Add php-cli as a dependency.
  • scl-suhosin

    • EA-8865: Add php-cli as a dependency.
  • scl-zendguard

    • EA-8865: Add php-cli as a dependency.
  • ea-apache24-mod_pagespeed

    • EA-8527: Move out of experimental to production.

2020-3-18

  • ea-nodejs10

    • EA-8895: Update ea-nodejs10 to 10.19.0, drop 10.18.1.
  • scl-ruby24-rubygem-nokogiri

    • EA-8901: Update to 1.10.9 from upstream.

2020-2-28

  • ea-tomcat85
    • EA-8885: Updated our setup script to handle changes to the 8.5.51 server.xml file.
    • EA-8886: Set secretRequired to false for the AJP connector.

2020-2-26

  • ea-openssl
    • EA-8870: Update ea-openssl to 1.0.2u, drop 1.0.2t (with fix for CVE-2019-1551).
  • ea-profiles-cpanel
    • EA-8864: Add php73 to the mpm_itk and worker profiles.
  • ea-tomcat85
    • EA-8875: Update ea-tomcat85 to 8.5.51, drop 8.5.50.
  • libcurl
    • EA-8843: Update libcurl to 7.68.0, drop 7.67.0 (with fix for CVE-2019-15601).
  • scl-php71
    • EA-8854: Fix circular dependencies in our PHP packages.
  • scl-php71-meta
    • EA-8854: Fix circular dependencies in our PHP packages.
  • scl-php72
  • scl-php72-meta
  • scl-php73
  • scl-php73-meta
  • scl-ruby24
    • ZC-6045: Remove conficting ownership.
  • scl-ruby24-rubygem-sqlite3
    • EA-8847: Update scl-ruby24-rubygem-sqlite3 to 1.4.2, drop 1.3.13.

2020-1-29

  • ea-apache2
    • COBRA-10700: Optimize finding a module.
  • ea-apache2-config
    • EA-8629: Prevent caching of defaultwebpage.cgi redirect.
  • ea-cpanel-tools
    • EA-8784: Add PHP 7.1 to EOL recommendations.
  • ea-freetds
    • EA-8839: Update to version 1.1.24 and make libtdsodbc.so available
  • ea-nodejs10
    • EA-8841: Update ea-nodejs10 to 10.18.1, drop 10.17.0.
  • ea-tomcat85
    • EA-8842: Update ea-tomcat85 to 8.5.50, drop 8.5.49.
  • mod_security2
    • EA-8753: Compile mod_security2 with yajl-devel for JSON.
  • scl-php72
  • scl-php72-meta
  • scl-php73
  • scl-php73-meta

2020-1-22

  • apr
    • ZC-4361: Update ea-openssl requirement to version 1.1.1.
  • apr-util
    • ZC-4361: Update ea-openssl requirement to version 1.1.1.
  • ea-apache2
    • ZC-4361: Update ea-openssl requirement to version 1.1.1.
  • ea-freetds
    • ZC-4361: Update ea-openssl requirement to version 1.1.1.
  • ea-nghttp2
    • ZC-4361: Update ea-openssl requirement to version 1.1.1.
  • libcurl
    • ZC-4361: Update ea-openssl requirement to version 1.1.1.
  • scl-libc-client
    • ZC-4361: Update ea-openssl requirement to version 1.1.1.
  • scl-php70
    • ZC-4361: Update ea-openssl requirement to version 1.1.1.
  • scl-php71
    • ZC-4361: Update ea-openssl requirement to version 1.1.1.
  • scl-php72
    • ZC-4361: Update ea-openssl requirement to version 1.1.1.
  • scl-php73
    • ZC-4361: Update ea-openssl requirement to version 1.1.1.

Additional Documentation